Git Integration for Jira Cloud Documentation

When a GIJ license expires, it shows up as a session error to the user

Problem

I’m getting an error message that says it’s a session error, SessionTokenNotFoundException, and I cannot proceed to use any GIJ features anymore.

 

Diagnosis

While session errors can just go away when the page is reloaded, this specific session error still remains. Jira admins will see a message similar to the one below:


 

Solution

Session error message that persist can mean that the trial or license to GIJ had expired. GIJ can detect a license expiration before it tries to detect a valid session. When valid, GIJ will display the correct message about the current license status.

Once you have renewed you Git Integration for Jira app license, this error message should stop appearing. Please note that if the license has been expired for too long, you might start seeing a different error noting ‘There is no Enabled installID’. If you start seeing this error message after renewing your license. Please submit a support request , as our dev team will need to manually enable your install.

Contact Us
If you still have a question – reach out to our Support Desk or email us at gijsupport@gitkraken.com.

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